// staticdata.dev — tlsVersions
// Generated file. Do not edit by hand.
// SPDX-License-Identifier: MIT

export const tlsVersions = [
  {
    "version": "SSL 2.0",
    "name": "SSL 2.0",
    "year": 1995,
    "rfc": null,
    "deprecated": true
  },
  {
    "version": "SSL 3.0",
    "name": "SSL 3.0",
    "year": 1996,
    "rfc": "RFC 6101",
    "deprecated": true
  },
  {
    "version": "TLS 1.0",
    "name": "TLS 1.0",
    "year": 1999,
    "rfc": "RFC 2246",
    "deprecated": true
  },
  {
    "version": "TLS 1.1",
    "name": "TLS 1.1",
    "year": 2006,
    "rfc": "RFC 4346",
    "deprecated": true
  },
  {
    "version": "TLS 1.2",
    "name": "TLS 1.2",
    "year": 2008,
    "rfc": "RFC 5246",
    "deprecated": false
  },
  {
    "version": "TLS 1.3",
    "name": "TLS 1.3",
    "year": 2018,
    "rfc": "RFC 8446",
    "deprecated": false
  }
] as const;

export type TlsVersion = (typeof tlsVersions)[number];
