// staticdata.dev — tlsCipherSuites
// Generated file. Do not edit by hand.
// SPDX-License-Identifier: MIT

export const tlsCipherSuites = [
  {
    "value": "0x00,0x00",
    "name": "TLS_NULL_WITH_NULL_NULL",
    "recommended": false,
    "reference": "[RFC5246]"
  },
  {
    "value": "0x00,0x01",
    "name": "TLS_RSA_WITH_NULL_MD5",
    "recommended": false,
    "reference": "[RFC5246][RFC10015]"
  },
  {
    "value": "0x00,0x02",
    "name": "TLS_RSA_WITH_NULL_SHA",
    "recommended": false,
    "reference": "[RFC5246][RFC10015]"
  },
  {
    "value": "0x00,0x03",
    "name": "TLS_RSA_EXPORT_WITH_RC4_40_MD5",
    "recommended": false,
    "reference": "[RFC4346][RFC6347][RFC10015]"
  },
  {
    "value": "0x00,0x04",
    "name": "TLS_RSA_WITH_RC4_128_MD5",
    "recommended": false,
    "reference": "[RFC5246][RFC6347][RFC10015]"
  },
  {
    "value": "0x00,0x05",
    "name": "TLS_RSA_WITH_RC4_128_SHA",
    "recommended": false,
    "reference": "[RFC5246][RFC6347][RFC10015]"
  },
  {
    "value": "0x00,0x06",
    "name": "TLS_RSA_EXPORT_WITH_RC2_CBC_40_MD5",
    "recommended": false,
    "reference": "[RFC4346][RFC10015]"
  },
  {
    "value": "0x00,0x07",
    "name": "TLS_RSA_WITH_IDEA_CBC_SHA",
    "recommended": false,
    "reference": "[RFC8996][RFC10015]"
  },
  {
    "value": "0x00,0x08",
    "name": "TLS_RSA_EXPORT_WITH_DES40_CBC_SHA",
    "recommended": false,
    "reference": "[RFC4346][RFC10015]"
  },
  {
    "value": "0x00,0x09",
    "name": "TLS_RSA_WITH_DES_CBC_SHA",
    "recommended": false,
    "reference": "[RFC8996][RFC10015]"
  },
  {
    "value": "0x00,0x0A",
    "name": "TLS_RSA_WITH_3DES_EDE_CBC_SHA",
    "recommended": false,
    "reference": "[RFC5246][RFC10015]"
  },
  {
    "value": "0x00,0x0B",
    "name": "TLS_DH_DSS_EXPORT_WITH_DES40_CBC_SHA",
    "recommended": false,
    "reference": "[RFC4346][RFC10015]"
  },
  {
    "value": "0x00,0x0C",
    "name": "TLS_DH_DSS_WITH_DES_CBC_SHA",
    "recommended": false,
    "reference": "[RFC8996][RFC10015]"
  },
  {
    "value": "0x00,0x0D",
    "name": "TLS_DH_DSS_WITH_3DES_EDE_CBC_SHA",
    "recommended": false,
    "reference": "[RFC5246][RFC10015]"
  },
  {
    "value": "0x00,0x0E",
    "name": "TLS_DH_RSA_EXPORT_WITH_DES40_CBC_SHA",
    "recommended": false,
    "reference": "[RFC4346][RFC10015]"
  },
  {
    "value": "0x00,0x0F",
    "name": "TLS_DH_RSA_WITH_DES_CBC_SHA",
    "recommended": false,
    "reference": "[RFC8996][RFC10015]"
  },
  {
    "value": "0x00,0x10",
    "name": "TLS_DH_RSA_WITH_3DES_EDE_CBC_SHA",
    "recommended": false,
    "reference": "[RFC5246][RFC10015]"
  },
  {
    "value": "0x00,0x11",
    "name": "TLS_DHE_DSS_EXPORT_WITH_DES40_CBC_SHA",
    "recommended": false,
    "reference": "[RFC4346][RFC10015]"
  },
  {
    "value": "0x00,0x12",
    "name": "TLS_DHE_DSS_WITH_DES_CBC_SHA",
    "recommended": false,
    "reference": "[RFC8996][RFC10015]"
  },
  {
    "value": "0x00,0x13",
    "name": "TLS_DHE_DSS_WITH_3DES_EDE_CBC_SHA",
    "recommended": false,
    "reference": "[RFC5246][RFC10015]"
  },
  {
    "value": "0x00,0x14",
    "name": "TLS_DHE_RSA_EXPORT_WITH_DES40_CBC_SHA",
    "recommended": false,
    "reference": "[RFC4346][RFC10015]"
  },
  {
    "value": "0x00,0x15",
    "name": "TLS_DHE_RSA_WITH_DES_CBC_SHA",
    "recommended": false,
    "reference": "[RFC8996][RFC10015]"
  },
  {
    "value": "0x00,0x16",
    "name": "TLS_DHE_RSA_WITH_3DES_EDE_CBC_SHA",
    "recommended": false,
    "reference": "[RFC5246][RFC10015]"
  },
  {
    "value": "0x00,0x17",
    "name": "TLS_DH_anon_EXPORT_WITH_RC4_40_MD5",
    "recommended": false,
    "reference": "[RFC4346][RFC6347][RFC10015]"
  },
  {
    "value": "0x00,0x18",
    "name": "TLS_DH_anon_WITH_RC4_128_MD5",
    "recommended": false,
    "reference": "[RFC5246][RFC6347][RFC10015]"
  },
  {
    "value": "0x00,0x19",
    "name": "TLS_DH_anon_EXPORT_WITH_DES40_CBC_SHA",
    "recommended": false,
    "reference": "[RFC4346][RFC10015]"
  },
  {
    "value": "0x00,0x1A",
    "name": "TLS_DH_anon_WITH_DES_CBC_SHA",
    "recommended": false,
    "reference": "[RFC8996][RFC10015]"
  },
  {
    "value": "0x00,0x1B",
    "name": "TLS_DH_anon_WITH_3DES_EDE_CBC_SHA",
    "recommended": false,
    "reference": "[RFC5246][RFC10015]"
  },
  {
    "value": "0x00,0x1E",
    "name": "TLS_KRB5_WITH_DES_CBC_SHA",
    "recommended": false,
    "reference": "[RFC2712][RFC9847]"
  },
  {
    "value": "0x00,0x1F",
    "name": "TLS_KRB5_WITH_3DES_EDE_CBC_SHA",
    "recommended": false,
    "reference": "[RFC2712]"
  },
  {
    "value": "0x00,0x20",
    "name": "TLS_KRB5_WITH_RC4_128_SHA",
    "recommended": false,
    "reference": "[RFC2712][RFC6347][RFC9847]"
  },
  {
    "value": "0x00,0x21",
    "name": "TLS_KRB5_WITH_IDEA_CBC_SHA",
    "recommended": false,
    "reference": "[RFC2712][RFC9847]"
  },
  {
    "value": "0x00,0x22",
    "name": "TLS_KRB5_WITH_DES_CBC_MD5",
    "recommended": false,
    "reference": "[RFC2712][RFC9847]"
  },
  {
    "value": "0x00,0x23",
    "name": "TLS_KRB5_WITH_3DES_EDE_CBC_MD5",
    "recommended": false,
    "reference": "[RFC2712]"
  },
  {
    "value": "0x00,0x24",
    "name": "TLS_KRB5_WITH_RC4_128_MD5",
    "recommended": false,
    "reference": "[RFC2712][RFC6347][RFC9847]"
  },
  {
    "value": "0x00,0x25",
    "name": "TLS_KRB5_WITH_IDEA_CBC_MD5",
    "recommended": false,
    "reference": "[RFC2712][RFC9847]"
  },
  {
    "value": "0x00,0x26",
    "name": "TLS_KRB5_EXPORT_WITH_DES_CBC_40_SHA",
    "recommended": false,
    "reference": "[RFC2712][RFC9847]"
  },
  {
    "value": "0x00,0x27",
    "name": "TLS_KRB5_EXPORT_WITH_RC2_CBC_40_SHA",
    "recommended": false,
    "reference": "[RFC2712][RFC9847]"
  },
  {
    "value": "0x00,0x28",
    "name": "TLS_KRB5_EXPORT_WITH_RC4_40_SHA",
    "recommended": false,
    "reference": "[RFC2712][RFC6347][RFC9847]"
  },
  {
    "value": "0x00,0x29",
    "name": "TLS_KRB5_EXPORT_WITH_DES_CBC_40_MD5",
    "recommended": false,
    "reference": "[RFC2712][RFC9847]"
  },
  {
    "value": "0x00,0x2A",
    "name": "TLS_KRB5_EXPORT_WITH_RC2_CBC_40_MD5",
    "recommended": false,
    "reference": "[RFC2712][RFC9847]"
  },
  {
    "value": "0x00,0x2B",
    "name": "TLS_KRB5_EXPORT_WITH_RC4_40_MD5",
    "recommended": false,
    "reference": "[RFC2712][RFC6347][RFC9847]"
  },
  {
    "value": "0x00,0x2C",
    "name": "TLS_PSK_WITH_NULL_SHA",
    "recommended": false,
    "reference": "[RFC4785][RFC9847]"
  },
  {
    "value": "0x00,0x2D",
    "name": "TLS_DHE_PSK_WITH_NULL_SHA",
    "recommended": false,
    "reference": "[RFC4785][RFC10015]"
  },
  {
    "value": "0x00,0x2E",
    "name": "TLS_RSA_PSK_WITH_NULL_SHA",
    "recommended": false,
    "reference": "[RFC4785][RFC10015]"
  },
  {
    "value": "0x00,0x2F",
    "name": "TLS_RSA_WITH_AES_128_CBC_SHA",
    "recommended": false,
    "reference": "[RFC5246][RFC10015]"
  },
  {
    "value": "0x00,0x30",
    "name": "TLS_DH_DSS_WITH_AES_128_CBC_SHA",
    "recommended": false,
    "reference": "[RFC5246][RFC10015]"
  },
  {
    "value": "0x00,0x31",
    "name": "TLS_DH_RSA_WITH_AES_128_CBC_SHA",
    "recommended": false,
    "reference": "[RFC5246][RFC10015]"
  },
  {
    "value": "0x00,0x32",
    "name": "TLS_DHE_DSS_WITH_AES_128_CBC_SHA",
    "recommended": false,
    "reference": "[RFC5246][RFC10015]"
  },
  {
    "value": "0x00,0x33",
    "name": "TLS_DHE_RSA_WITH_AES_128_CBC_SHA",
    "recommended": false,
    "reference": "[RFC5246][RFC10015]"
  },
  {
    "value": "0x00,0x34",
    "name": "TLS_DH_anon_WITH_AES_128_CBC_SHA",
    "recommended": false,
    "reference": "[RFC5246][RFC10015]"
  },
  {
    "value": "0x00,0x35",
    "name": "TLS_RSA_WITH_AES_256_CBC_SHA",
    "recommended": false,
    "reference": "[RFC5246][RFC10015]"
  },
  {
    "value": "0x00,0x36",
    "name": "TLS_DH_DSS_WITH_AES_256_CBC_SHA",
    "recommended": false,
    "reference": "[RFC5246][RFC10015]"
  },
  {
    "value": "0x00,0x37",
    "name": "TLS_DH_RSA_WITH_AES_256_CBC_SHA",
    "recommended": false,
    "reference": "[RFC5246][RFC10015]"
  },
  {
    "value": "0x00,0x38",
    "name": "TLS_DHE_DSS_WITH_AES_256_CBC_SHA",
    "recommended": false,
    "reference": "[RFC5246][RFC10015]"
  },
  {
    "value": "0x00,0x39",
    "name": "TLS_DHE_RSA_WITH_AES_256_CBC_SHA",
    "recommended": false,
    "reference": "[RFC5246][RFC10015]"
  },
  {
    "value": "0x00,0x3A",
    "name": "TLS_DH_anon_WITH_AES_256_CBC_SHA",
    "recommended": false,
    "reference": "[RFC5246][RFC10015]"
  },
  {
    "value": "0x00,0x3B",
    "name": "TLS_RSA_WITH_NULL_SHA256",
    "recommended": false,
    "reference": "[RFC5246][RFC10015]"
  },
  {
    "value": "0x00,0x3C",
    "name": "TLS_RSA_WITH_AES_128_CBC_SHA256",
    "recommended": false,
    "reference": "[RFC5246][RFC10015]"
  },
  {
    "value": "0x00,0x3D",
    "name": "TLS_RSA_WITH_AES_256_CBC_SHA256",
    "recommended": false,
    "reference": "[RFC5246][RFC10015]"
  },
  {
    "value": "0x00,0x3E",
    "name": "TLS_DH_DSS_WITH_AES_128_CBC_SHA256",
    "recommended": false,
    "reference": "[RFC5246][RFC10015]"
  },
  {
    "value": "0x00,0x3F",
    "name": "TLS_DH_RSA_WITH_AES_128_CBC_SHA256",
    "recommended": false,
    "reference": "[RFC5246][RFC10015]"
  },
  {
    "value": "0x00,0x40",
    "name": "TLS_DHE_DSS_WITH_AES_128_CBC_SHA256",
    "recommended": false,
    "reference": "[RFC5246][RFC10015]"
  },
  {
    "value": "0x00,0x41",
    "name": "TLS_RSA_WITH_CAMELLIA_128_CBC_SHA",
    "recommended": false,
    "reference": "[RFC5932][RFC10015]"
  },
  {
    "value": "0x00,0x42",
    "name": "TLS_DH_DSS_WITH_CAMELLIA_128_CBC_SHA",
    "recommended": false,
    "reference": "[RFC5932][RFC10015]"
  },
  {
    "value": "0x00,0x43",
    "name": "TLS_DH_RSA_WITH_CAMELLIA_128_CBC_SHA",
    "recommended": false,
    "reference": "[RFC5932][RFC10015]"
  },
  {
    "value": "0x00,0x44",
    "name": "TLS_DHE_DSS_WITH_CAMELLIA_128_CBC_SHA",
    "recommended": false,
    "reference": "[RFC5932][RFC10015]"
  },
  {
    "value": "0x00,0x45",
    "name": "TLS_DHE_RSA_WITH_CAMELLIA_128_CBC_SHA",
    "recommended": false,
    "reference": "[RFC5932][RFC10015]"
  },
  {
    "value": "0x00,0x46",
    "name": "TLS_DH_anon_WITH_CAMELLIA_128_CBC_SHA",
    "recommended": false,
    "reference": "[RFC5932][RFC10015]"
  },
  {
    "value": "0x00,0x67",
    "name": "TLS_DHE_RSA_WITH_AES_128_CBC_SHA256",
    "recommended": false,
    "reference": "[RFC5246][RFC10015]"
  },
  {
    "value": "0x00,0x68",
    "name": "TLS_DH_DSS_WITH_AES_256_CBC_SHA256",
    "recommended": false,
    "reference": "[RFC5246][RFC10015]"
  },
  {
    "value": "0x00,0x69",
    "name": "TLS_DH_RSA_WITH_AES_256_CBC_SHA256",
    "recommended": false,
    "reference": "[RFC5246][RFC10015]"
  },
  {
    "value": "0x00,0x6A",
    "name": "TLS_DHE_DSS_WITH_AES_256_CBC_SHA256",
    "recommended": false,
    "reference": "[RFC5246][RFC10015]"
  },
  {
    "value": "0x00,0x6B",
    "name": "TLS_DHE_RSA_WITH_AES_256_CBC_SHA256",
    "recommended": false,
    "reference": "[RFC5246][RFC10015]"
  },
  {
    "value": "0x00,0x6C",
    "name": "TLS_DH_anon_WITH_AES_128_CBC_SHA256",
    "recommended": false,
    "reference": "[RFC5246][RFC10015]"
  },
  {
    "value": "0x00,0x6D",
    "name": "TLS_DH_anon_WITH_AES_256_CBC_SHA256",
    "recommended": false,
    "reference": "[RFC5246][RFC10015]"
  },
  {
    "value": "0x00,0x6E",
    "name": "TLS_ASCONAEAD128_ASCONHASH256",
    "recommended": false,
    "reference": "[https://doi.org/10.6028/NIST.SP.800-232]"
  },
  {
    "value": "0x00,0x6F",
    "name": "TLS_ASCONAEAD128_SHA256",
    "recommended": false,
    "reference": "[https://doi.org/10.6028/NIST.SP.800-232][RFC9846]"
  },
  {
    "value": "0x00,0x70",
    "name": "TLS_AES_128_GCM_ASCONHASH256",
    "recommended": false,
    "reference": "[https://doi.org/10.6028/NIST.SP.800-232][RFC9846]"
  },
  {
    "value": "0x00,0x71",
    "name": "TLS_AES_128_CCM_ASCONHASH256",
    "recommended": false,
    "reference": "[https://doi.org/10.6028/NIST.SP.800-232][RFC9846]"
  },
  {
    "value": "0x00,0x84",
    "name": "TLS_RSA_WITH_CAMELLIA_256_CBC_SHA",
    "recommended": false,
    "reference": "[RFC5932][RFC10015]"
  },
  {
    "value": "0x00,0x85",
    "name": "TLS_DH_DSS_WITH_CAMELLIA_256_CBC_SHA",
    "recommended": false,
    "reference": "[RFC5932][RFC10015]"
  },
  {
    "value": "0x00,0x86",
    "name": "TLS_DH_RSA_WITH_CAMELLIA_256_CBC_SHA",
    "recommended": false,
    "reference": "[RFC5932][RFC10015]"
  },
  {
    "value": "0x00,0x87",
    "name": "TLS_DHE_DSS_WITH_CAMELLIA_256_CBC_SHA",
    "recommended": false,
    "reference": "[RFC5932][RFC10015]"
  },
  {
    "value": "0x00,0x88",
    "name": "TLS_DHE_RSA_WITH_CAMELLIA_256_CBC_SHA",
    "recommended": false,
    "reference": "[RFC5932][RFC10015]"
  },
  {
    "value": "0x00,0x89",
    "name": "TLS_DH_anon_WITH_CAMELLIA_256_CBC_SHA",
    "recommended": false,
    "reference": "[RFC5932][RFC10015]"
  },
  {
    "value": "0x00,0x8A",
    "name": "TLS_PSK_WITH_RC4_128_SHA",
    "recommended": false,
    "reference": "[RFC4279][RFC6347][RFC9847]"
  },
  {
    "value": "0x00,0x8B",
    "name": "TLS_PSK_WITH_3DES_EDE_CBC_SHA",
    "recommended": false,
    "reference": "[RFC4279]"
  },
  {
    "value": "0x00,0x8C",
    "name": "TLS_PSK_WITH_AES_128_CBC_SHA",
    "recommended": false,
    "reference": "[RFC4279]"
  },
  {
    "value": "0x00,0x8D",
    "name": "TLS_PSK_WITH_AES_256_CBC_SHA",
    "recommended": false,
    "reference": "[RFC4279]"
  },
  {
    "value": "0x00,0x8E",
    "name": "TLS_DHE_PSK_WITH_RC4_128_SHA",
    "recommended": false,
    "reference": "[RFC4279][RFC6347][RFC10015]"
  },
  {
    "value": "0x00,0x8F",
    "name": "TLS_DHE_PSK_WITH_3DES_EDE_CBC_SHA",
    "recommended": false,
    "reference": "[RFC4279][RFC10015]"
  },
  {
    "value": "0x00,0x90",
    "name": "TLS_DHE_PSK_WITH_AES_128_CBC_SHA",
    "recommended": false,
    "reference": "[RFC4279][RFC10015]"
  },
  {
    "value": "0x00,0x91",
    "name": "TLS_DHE_PSK_WITH_AES_256_CBC_SHA",
    "recommended": false,
    "reference": "[RFC4279][RFC10015]"
  },
  {
    "value": "0x00,0x92",
    "name": "TLS_RSA_PSK_WITH_RC4_128_SHA",
    "recommended": false,
    "reference": "[RFC4279][RFC6347][RFC10015]"
  },
  {
    "value": "0x00,0x93",
    "name": "TLS_RSA_PSK_WITH_3DES_EDE_CBC_SHA",
    "recommended": false,
    "reference": "[RFC4279][RFC10015]"
  },
  {
    "value": "0x00,0x94",
    "name": "TLS_RSA_PSK_WITH_AES_128_CBC_SHA",
    "recommended": false,
    "reference": "[RFC4279][RFC10015]"
  },
  {
    "value": "0x00,0x95",
    "name": "TLS_RSA_PSK_WITH_AES_256_CBC_SHA",
    "recommended": false,
    "reference": "[RFC4279][RFC10015]"
  },
  {
    "value": "0x00,0x96",
    "name": "TLS_RSA_WITH_SEED_CBC_SHA",
    "recommended": false,
    "reference": "[RFC4162][RFC10015]"
  },
  {
    "value": "0x00,0x97",
    "name": "TLS_DH_DSS_WITH_SEED_CBC_SHA",
    "recommended": false,
    "reference": "[RFC4162][RFC10015]"
  },
  {
    "value": "0x00,0x98",
    "name": "TLS_DH_RSA_WITH_SEED_CBC_SHA",
    "recommended": false,
    "reference": "[RFC4162][RFC10015]"
  },
  {
    "value": "0x00,0x99",
    "name": "TLS_DHE_DSS_WITH_SEED_CBC_SHA",
    "recommended": false,
    "reference": "[RFC4162][RFC10015]"
  },
  {
    "value": "0x00,0x9A",
    "name": "TLS_DHE_RSA_WITH_SEED_CBC_SHA",
    "recommended": false,
    "reference": "[RFC4162][RFC10015]"
  },
  {
    "value": "0x00,0x9B",
    "name": "TLS_DH_anon_WITH_SEED_CBC_SHA",
    "recommended": false,
    "reference": "[RFC4162][RFC10015]"
  },
  {
    "value": "0x00,0x9C",
    "name": "TLS_RSA_WITH_AES_128_GCM_SHA256",
    "recommended": false,
    "reference": "[RFC5288][RFC10015]"
  },
  {
    "value": "0x00,0x9D",
    "name": "TLS_RSA_WITH_AES_256_GCM_SHA384",
    "recommended": false,
    "reference": "[RFC5288][RFC10015]"
  },
  {
    "value": "0x00,0x9E",
    "name": "TLS_DHE_RSA_WITH_AES_128_GCM_SHA256",
    "recommended": false,
    "reference": "[RFC5288][RFC10015]"
  },
  {
    "value": "0x00,0x9F",
    "name": "TLS_DHE_RSA_WITH_AES_256_GCM_SHA384",
    "recommended": false,
    "reference": "[RFC5288][RFC10015]"
  },
  {
    "value": "0x00,0xA0",
    "name": "TLS_DH_RSA_WITH_AES_128_GCM_SHA256",
    "recommended": false,
    "reference": "[RFC5288][RFC10015]"
  },
  {
    "value": "0x00,0xA1",
    "name": "TLS_DH_RSA_WITH_AES_256_GCM_SHA384",
    "recommended": false,
    "reference": "[RFC5288][RFC10015]"
  },
  {
    "value": "0x00,0xA2",
    "name": "TLS_DHE_DSS_WITH_AES_128_GCM_SHA256",
    "recommended": false,
    "reference": "[RFC5288][RFC10015]"
  },
  {
    "value": "0x00,0xA3",
    "name": "TLS_DHE_DSS_WITH_AES_256_GCM_SHA384",
    "recommended": false,
    "reference": "[RFC5288][RFC10015]"
  },
  {
    "value": "0x00,0xA4",
    "name": "TLS_DH_DSS_WITH_AES_128_GCM_SHA256",
    "recommended": false,
    "reference": "[RFC5288][RFC10015]"
  },
  {
    "value": "0x00,0xA5",
    "name": "TLS_DH_DSS_WITH_AES_256_GCM_SHA384",
    "recommended": false,
    "reference": "[RFC5288][RFC10015]"
  },
  {
    "value": "0x00,0xA6",
    "name": "TLS_DH_anon_WITH_AES_128_GCM_SHA256",
    "recommended": false,
    "reference": "[RFC5288][RFC10015]"
  },
  {
    "value": "0x00,0xA7",
    "name": "TLS_DH_anon_WITH_AES_256_GCM_SHA384",
    "recommended": false,
    "reference": "[RFC5288][RFC10015]"
  },
  {
    "value": "0x00,0xA8",
    "name": "TLS_PSK_WITH_AES_128_GCM_SHA256",
    "recommended": false,
    "reference": "[RFC5487]"
  },
  {
    "value": "0x00,0xA9",
    "name": "TLS_PSK_WITH_AES_256_GCM_SHA384",
    "recommended": false,
    "reference": "[RFC5487]"
  },
  {
    "value": "0x00,0xAA",
    "name": "TLS_DHE_PSK_WITH_AES_128_GCM_SHA256",
    "recommended": false,
    "reference": "[RFC5487][RFC10015]"
  },
  {
    "value": "0x00,0xAB",
    "name": "TLS_DHE_PSK_WITH_AES_256_GCM_SHA384",
    "recommended": false,
    "reference": "[RFC5487][RFC10015]"
  },
  {
    "value": "0x00,0xAC",
    "name": "TLS_RSA_PSK_WITH_AES_128_GCM_SHA256",
    "recommended": false,
    "reference": "[RFC5487][RFC10015]"
  },
  {
    "value": "0x00,0xAD",
    "name": "TLS_RSA_PSK_WITH_AES_256_GCM_SHA384",
    "recommended": false,
    "reference": "[RFC5487][RFC10015]"
  },
  {
    "value": "0x00,0xAE",
    "name": "TLS_PSK_WITH_AES_128_CBC_SHA256",
    "recommended": false,
    "reference": "[RFC5487]"
  },
  {
    "value": "0x00,0xAF",
    "name": "TLS_PSK_WITH_AES_256_CBC_SHA384",
    "recommended": false,
    "reference": "[RFC5487]"
  },
  {
    "value": "0x00,0xB0",
    "name": "TLS_PSK_WITH_NULL_SHA256",
    "recommended": false,
    "reference": "[RFC5487][RFC9847]"
  },
  {
    "value": "0x00,0xB1",
    "name": "TLS_PSK_WITH_NULL_SHA384",
    "recommended": false,
    "reference": "[RFC5487][RFC9847]"
  },
  {
    "value": "0x00,0xB2",
    "name": "TLS_DHE_PSK_WITH_AES_128_CBC_SHA256",
    "recommended": false,
    "reference": "[RFC5487][RFC10015]"
  },
  {
    "value": "0x00,0xB3",
    "name": "TLS_DHE_PSK_WITH_AES_256_CBC_SHA384",
    "recommended": false,
    "reference": "[RFC5487][RFC10015]"
  },
  {
    "value": "0x00,0xB4",
    "name": "TLS_DHE_PSK_WITH_NULL_SHA256",
    "recommended": false,
    "reference": "[RFC5487][RFC10015]"
  },
  {
    "value": "0x00,0xB5",
    "name": "TLS_DHE_PSK_WITH_NULL_SHA384",
    "recommended": false,
    "reference": "[RFC5487][RFC10015]"
  },
  {
    "value": "0x00,0xB6",
    "name": "TLS_RSA_PSK_WITH_AES_128_CBC_SHA256",
    "recommended": false,
    "reference": "[RFC5487][RFC10015]"
  },
  {
    "value": "0x00,0xB7",
    "name": "TLS_RSA_PSK_WITH_AES_256_CBC_SHA384",
    "recommended": false,
    "reference": "[RFC5487][RFC10015]"
  },
  {
    "value": "0x00,0xB8",
    "name": "TLS_RSA_PSK_WITH_NULL_SHA256",
    "recommended": false,
    "reference": "[RFC5487][RFC10015]"
  },
  {
    "value": "0x00,0xB9",
    "name": "TLS_RSA_PSK_WITH_NULL_SHA384",
    "recommended": false,
    "reference": "[RFC5487][RFC10015]"
  },
  {
    "value": "0x00,0xBA",
    "name": "TLS_RSA_WITH_CAMELLIA_128_CBC_SHA256",
    "recommended": false,
    "reference": "[RFC5932][RFC10015]"
  },
  {
    "value": "0x00,0xBB",
    "name": "TLS_DH_DSS_WITH_CAMELLIA_128_CBC_SHA256",
    "recommended": false,
    "reference": "[RFC5932][RFC10015]"
  },
  {
    "value": "0x00,0xBC",
    "name": "TLS_DH_RSA_WITH_CAMELLIA_128_CBC_SHA256",
    "recommended": false,
    "reference": "[RFC5932][RFC10015]"
  },
  {
    "value": "0x00,0xBD",
    "name": "TLS_DHE_DSS_WITH_CAMELLIA_128_CBC_SHA256",
    "recommended": false,
    "reference": "[RFC5932][RFC10015]"
  },
  {
    "value": "0x00,0xBE",
    "name": "TLS_DHE_RSA_WITH_CAMELLIA_128_CBC_SHA256",
    "recommended": false,
    "reference": "[RFC5932][RFC10015]"
  },
  {
    "value": "0x00,0xBF",
    "name": "TLS_DH_anon_WITH_CAMELLIA_128_CBC_SHA256",
    "recommended": false,
    "reference": "[RFC5932][RFC10015]"
  },
  {
    "value": "0x00,0xC0",
    "name": "TLS_RSA_WITH_CAMELLIA_256_CBC_SHA256",
    "recommended": false,
    "reference": "[RFC5932][RFC10015]"
  },
  {
    "value": "0x00,0xC1",
    "name": "TLS_DH_DSS_WITH_CAMELLIA_256_CBC_SHA256",
    "recommended": false,
    "reference": "[RFC5932][RFC10015]"
  },
  {
    "value": "0x00,0xC2",
    "name": "TLS_DH_RSA_WITH_CAMELLIA_256_CBC_SHA256",
    "recommended": false,
    "reference": "[RFC5932][RFC10015]"
  },
  {
    "value": "0x00,0xC3",
    "name": "TLS_DHE_DSS_WITH_CAMELLIA_256_CBC_SHA256",
    "recommended": false,
    "reference": "[RFC5932][RFC10015]"
  },
  {
    "value": "0x00,0xC4",
    "name": "TLS_DHE_RSA_WITH_CAMELLIA_256_CBC_SHA256",
    "recommended": false,
    "reference": "[RFC5932][RFC10015]"
  },
  {
    "value": "0x00,0xC5",
    "name": "TLS_DH_anon_WITH_CAMELLIA_256_CBC_SHA256",
    "recommended": false,
    "reference": "[RFC5932][RFC10015]"
  },
  {
    "value": "0x00,0xC6",
    "name": "TLS_SM4_GCM_SM3",
    "recommended": false,
    "reference": "[RFC8998]"
  },
  {
    "value": "0x00,0xC7",
    "name": "TLS_SM4_CCM_SM3",
    "recommended": false,
    "reference": "[RFC8998]"
  },
  {
    "value": "0x00,0xFF",
    "name": "TLS_EMPTY_RENEGOTIATION_INFO_SCSV",
    "recommended": false,
    "reference": "[RFC5746]"
  },
  {
    "value": "0x13,0x01",
    "name": "TLS_AES_128_GCM_SHA256",
    "recommended": true,
    "reference": "[RFC9846]"
  },
  {
    "value": "0x13,0x02",
    "name": "TLS_AES_256_GCM_SHA384",
    "recommended": true,
    "reference": "[RFC9846]"
  },
  {
    "value": "0x13,0x03",
    "name": "TLS_CHACHA20_POLY1305_SHA256",
    "recommended": true,
    "reference": "[RFC9846]"
  },
  {
    "value": "0x13,0x04",
    "name": "TLS_AES_128_CCM_SHA256",
    "recommended": true,
    "reference": "[RFC9846]"
  },
  {
    "value": "0x13,0x05",
    "name": "TLS_AES_128_CCM_8_SHA256",
    "recommended": false,
    "reference": "[RFC9846][IESG Action 2018-08-16]"
  },
  {
    "value": "0x13,0x06",
    "name": "TLS_AEGIS_256_SHA512",
    "recommended": false,
    "reference": "[draft-irtf-cfrg-aegis-aead-08]"
  },
  {
    "value": "0x13,0x07",
    "name": "TLS_AEGIS_128L_SHA256",
    "recommended": false,
    "reference": "[draft-irtf-cfrg-aegis-aead-08]"
  },
  {
    "value": "0x56,0x00",
    "name": "TLS_FALLBACK_SCSV",
    "recommended": false,
    "reference": "[RFC7507]"
  },
  {
    "value": "0xC0,0x01",
    "name": "TLS_ECDH_ECDSA_WITH_NULL_SHA",
    "recommended": false,
    "reference": "[RFC8422][RFC10015]"
  },
  {
    "value": "0xC0,0x02",
    "name": "TLS_ECDH_ECDSA_WITH_RC4_128_SHA",
    "recommended": false,
    "reference": "[RFC8422][RFC6347][RFC10015]"
  },
  {
    "value": "0xC0,0x03",
    "name": "TLS_ECDH_ECDSA_WITH_3DES_EDE_CBC_SHA",
    "recommended": false,
    "reference": "[RFC8422][RFC10015]"
  },
  {
    "value": "0xC0,0x04",
    "name": "TLS_ECDH_ECDSA_WITH_AES_128_CBC_SHA",
    "recommended": false,
    "reference": "[RFC8422][RFC10015]"
  },
  {
    "value": "0xC0,0x05",
    "name": "TLS_ECDH_ECDSA_WITH_AES_256_CBC_SHA",
    "recommended": false,
    "reference": "[RFC8422][RFC10015]"
  },
  {
    "value": "0xC0,0x06",
    "name": "TLS_ECDHE_ECDSA_WITH_NULL_SHA",
    "recommended": false,
    "reference": "[RFC8422][RFC9847]"
  },
  {
    "value": "0xC0,0x07",
    "name": "TLS_ECDHE_ECDSA_WITH_RC4_128_SHA",
    "recommended": false,
    "reference": "[RFC8422][RFC6347][RFC9847]"
  },
  {
    "value": "0xC0,0x08",
    "name": "TLS_ECDHE_ECDSA_WITH_3DES_EDE_CBC_SHA",
    "recommended": false,
    "reference": "[RFC8422]"
  },
  {
    "value": "0xC0,0x09",
    "name": "TLS_ECDHE_ECDSA_WITH_AES_128_CBC_SHA",
    "recommended": false,
    "reference": "[RFC8422]"
  },
  {
    "value": "0xC0,0x0A",
    "name": "TLS_ECDHE_ECDSA_WITH_AES_256_CBC_SHA",
    "recommended": false,
    "reference": "[RFC8422]"
  },
  {
    "value": "0xC0,0x0B",
    "name": "TLS_ECDH_RSA_WITH_NULL_SHA",
    "recommended": false,
    "reference": "[RFC8422][RFC10015]"
  },
  {
    "value": "0xC0,0x0C",
    "name": "TLS_ECDH_RSA_WITH_RC4_128_SHA",
    "recommended": false,
    "reference": "[RFC8422][RFC6347][RFC10015]"
  },
  {
    "value": "0xC0,0x0D",
    "name": "TLS_ECDH_RSA_WITH_3DES_EDE_CBC_SHA",
    "recommended": false,
    "reference": "[RFC8422][RFC10015]"
  },
  {
    "value": "0xC0,0x0E",
    "name": "TLS_ECDH_RSA_WITH_AES_128_CBC_SHA",
    "recommended": false,
    "reference": "[RFC8422][RFC10015]"
  },
  {
    "value": "0xC0,0x0F",
    "name": "TLS_ECDH_RSA_WITH_AES_256_CBC_SHA",
    "recommended": false,
    "reference": "[RFC8422][RFC10015]"
  },
  {
    "value": "0xC0,0x10",
    "name": "TLS_ECDHE_RSA_WITH_NULL_SHA",
    "recommended": false,
    "reference": "[RFC8422][RFC9847]"
  },
  {
    "value": "0xC0,0x11",
    "name": "TLS_ECDHE_RSA_WITH_RC4_128_SHA",
    "recommended": false,
    "reference": "[RFC8422][RFC6347][RFC9847]"
  },
  {
    "value": "0xC0,0x12",
    "name": "TLS_ECDHE_RSA_WITH_3DES_EDE_CBC_SHA",
    "recommended": false,
    "reference": "[RFC8422]"
  },
  {
    "value": "0xC0,0x13",
    "name": "TLS_ECDHE_RSA_WITH_AES_128_CBC_SHA",
    "recommended": false,
    "reference": "[RFC8422]"
  },
  {
    "value": "0xC0,0x14",
    "name": "TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA",
    "recommended": false,
    "reference": "[RFC8422]"
  },
  {
    "value": "0xC0,0x15",
    "name": "TLS_ECDH_anon_WITH_NULL_SHA",
    "recommended": false,
    "reference": "[RFC8422][RFC10015]"
  },
  {
    "value": "0xC0,0x16",
    "name": "TLS_ECDH_anon_WITH_RC4_128_SHA",
    "recommended": false,
    "reference": "[RFC8422][RFC6347][RFC10015]"
  },
  {
    "value": "0xC0,0x17",
    "name": "TLS_ECDH_anon_WITH_3DES_EDE_CBC_SHA",
    "recommended": false,
    "reference": "[RFC8422][RFC10015]"
  },
  {
    "value": "0xC0,0x18",
    "name": "TLS_ECDH_anon_WITH_AES_128_CBC_SHA",
    "recommended": false,
    "reference": "[RFC8422][RFC10015]"
  },
  {
    "value": "0xC0,0x19",
    "name": "TLS_ECDH_anon_WITH_AES_256_CBC_SHA",
    "recommended": false,
    "reference": "[RFC8422][RFC10015]"
  },
  {
    "value": "0xC0,0x1A",
    "name": "TLS_SRP_SHA_WITH_3DES_EDE_CBC_SHA",
    "recommended": false,
    "reference": "[RFC5054]"
  },
  {
    "value": "0xC0,0x1B",
    "name": "TLS_SRP_SHA_RSA_WITH_3DES_EDE_CBC_SHA",
    "recommended": false,
    "reference": "[RFC5054]"
  },
  {
    "value": "0xC0,0x1C",
    "name": "TLS_SRP_SHA_DSS_WITH_3DES_EDE_CBC_SHA",
    "recommended": false,
    "reference": "[RFC5054]"
  },
  {
    "value": "0xC0,0x1D",
    "name": "TLS_SRP_SHA_WITH_AES_128_CBC_SHA",
    "recommended": false,
    "reference": "[RFC5054]"
  },
  {
    "value": "0xC0,0x1E",
    "name": "TLS_SRP_SHA_RSA_WITH_AES_128_CBC_SHA",
    "recommended": false,
    "reference": "[RFC5054]"
  },
  {
    "value": "0xC0,0x1F",
    "name": "TLS_SRP_SHA_DSS_WITH_AES_128_CBC_SHA",
    "recommended": false,
    "reference": "[RFC5054]"
  },
  {
    "value": "0xC0,0x20",
    "name": "TLS_SRP_SHA_WITH_AES_256_CBC_SHA",
    "recommended": false,
    "reference": "[RFC5054]"
  },
  {
    "value": "0xC0,0x21",
    "name": "TLS_SRP_SHA_RSA_WITH_AES_256_CBC_SHA",
    "recommended": false,
    "reference": "[RFC5054]"
  },
  {
    "value": "0xC0,0x22",
    "name": "TLS_SRP_SHA_DSS_WITH_AES_256_CBC_SHA",
    "recommended": false,
    "reference": "[RFC5054]"
  },
  {
    "value": "0xC0,0x23",
    "name": "TLS_ECDHE_ECDSA_WITH_AES_128_CBC_SHA256",
    "recommended": false,
    "reference": "[RFC5289]"
  },
  {
    "value": "0xC0,0x24",
    "name": "TLS_ECDHE_ECDSA_WITH_AES_256_CBC_SHA384",
    "recommended": false,
    "reference": "[RFC5289]"
  },
  {
    "value": "0xC0,0x25",
    "name": "TLS_ECDH_ECDSA_WITH_AES_128_CBC_SHA256",
    "recommended": false,
    "reference": "[RFC5289][RFC10015]"
  },
  {
    "value": "0xC0,0x26",
    "name": "TLS_ECDH_ECDSA_WITH_AES_256_CBC_SHA384",
    "recommended": false,
    "reference": "[RFC5289][RFC10015]"
  },
  {
    "value": "0xC0,0x27",
    "name": "TLS_ECDHE_RSA_WITH_AES_128_CBC_SHA256",
    "recommended": false,
    "reference": "[RFC5289]"
  },
  {
    "value": "0xC0,0x28",
    "name": "TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA384",
    "recommended": false,
    "reference": "[RFC5289]"
  },
  {
    "value": "0xC0,0x29",
    "name": "TLS_ECDH_RSA_WITH_AES_128_CBC_SHA256",
    "recommended": false,
    "reference": "[RFC5289][RFC10015]"
  },
  {
    "value": "0xC0,0x2A",
    "name": "TLS_ECDH_RSA_WITH_AES_256_CBC_SHA384",
    "recommended": false,
    "reference": "[RFC5289][RFC10015]"
  },
  {
    "value": "0xC0,0x2B",
    "name": "TLS_ECDHE_ECDSA_WITH_AES_128_GCM_SHA256",
    "recommended": true,
    "reference": "[RFC5289]"
  },
  {
    "value": "0xC0,0x2C",
    "name": "TLS_ECDHE_ECDSA_WITH_AES_256_GCM_SHA384",
    "recommended": true,
    "reference": "[RFC5289]"
  },
  {
    "value": "0xC0,0x2D",
    "name": "TLS_ECDH_ECDSA_WITH_AES_128_GCM_SHA256",
    "recommended": false,
    "reference": "[RFC5289][RFC10015]"
  },
  {
    "value": "0xC0,0x2E",
    "name": "TLS_ECDH_ECDSA_WITH_AES_256_GCM_SHA384",
    "recommended": false,
    "reference": "[RFC5289][RFC10015]"
  },
  {
    "value": "0xC0,0x2F",
    "name": "TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256",
    "recommended": true,
    "reference": "[RFC5289]"
  },
  {
    "value": "0xC0,0x30",
    "name": "TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384",
    "recommended": true,
    "reference": "[RFC5289]"
  },
  {
    "value": "0xC0,0x31",
    "name": "TLS_ECDH_RSA_WITH_AES_128_GCM_SHA256",
    "recommended": false,
    "reference": "[RFC5289][RFC10015]"
  },
  {
    "value": "0xC0,0x32",
    "name": "TLS_ECDH_RSA_WITH_AES_256_GCM_SHA384",
    "recommended": false,
    "reference": "[RFC5289][RFC10015]"
  },
  {
    "value": "0xC0,0x33",
    "name": "TLS_ECDHE_PSK_WITH_RC4_128_SHA",
    "recommended": false,
    "reference": "[RFC5489][RFC6347][RFC9847]"
  },
  {
    "value": "0xC0,0x34",
    "name": "TLS_ECDHE_PSK_WITH_3DES_EDE_CBC_SHA",
    "recommended": false,
    "reference": "[RFC5489]"
  },
  {
    "value": "0xC0,0x35",
    "name": "TLS_ECDHE_PSK_WITH_AES_128_CBC_SHA",
    "recommended": false,
    "reference": "[RFC5489]"
  },
  {
    "value": "0xC0,0x36",
    "name": "TLS_ECDHE_PSK_WITH_AES_256_CBC_SHA",
    "recommended": false,
    "reference": "[RFC5489]"
  },
  {
    "value": "0xC0,0x37",
    "name": "TLS_ECDHE_PSK_WITH_AES_128_CBC_SHA256",
    "recommended": false,
    "reference": "[RFC5489]"
  },
  {
    "value": "0xC0,0x38",
    "name": "TLS_ECDHE_PSK_WITH_AES_256_CBC_SHA384",
    "recommended": false,
    "reference": "[RFC5489]"
  },
  {
    "value": "0xC0,0x39",
    "name": "TLS_ECDHE_PSK_WITH_NULL_SHA",
    "recommended": false,
    "reference": "[RFC5489][RFC9847]"
  },
  {
    "value": "0xC0,0x3A",
    "name": "TLS_ECDHE_PSK_WITH_NULL_SHA256",
    "recommended": false,
    "reference": "[RFC5489][RFC9847]"
  },
  {
    "value": "0xC0,0x3B",
    "name": "TLS_ECDHE_PSK_WITH_NULL_SHA384",
    "recommended": false,
    "reference": "[RFC5489][RFC9847]"
  },
  {
    "value": "0xC0,0x3C",
    "name": "TLS_RSA_WITH_ARIA_128_CBC_SHA256",
    "recommended": false,
    "reference": "[RFC6209][RFC10015]"
  },
  {
    "value": "0xC0,0x3D",
    "name": "TLS_RSA_WITH_ARIA_256_CBC_SHA384",
    "recommended": false,
    "reference": "[RFC6209][RFC10015]"
  },
  {
    "value": "0xC0,0x3E",
    "name": "TLS_DH_DSS_WITH_ARIA_128_CBC_SHA256",
    "recommended": false,
    "reference": "[RFC6209][RFC10015]"
  },
  {
    "value": "0xC0,0x3F",
    "name": "TLS_DH_DSS_WITH_ARIA_256_CBC_SHA384",
    "recommended": false,
    "reference": "[RFC6209][RFC10015]"
  },
  {
    "value": "0xC0,0x40",
    "name": "TLS_DH_RSA_WITH_ARIA_128_CBC_SHA256",
    "recommended": false,
    "reference": "[RFC6209][RFC10015]"
  },
  {
    "value": "0xC0,0x41",
    "name": "TLS_DH_RSA_WITH_ARIA_256_CBC_SHA384",
    "recommended": false,
    "reference": "[RFC6209][RFC10015]"
  },
  {
    "value": "0xC0,0x42",
    "name": "TLS_DHE_DSS_WITH_ARIA_128_CBC_SHA256",
    "recommended": false,
    "reference": "[RFC6209][RFC10015]"
  },
  {
    "value": "0xC0,0x43",
    "name": "TLS_DHE_DSS_WITH_ARIA_256_CBC_SHA384",
    "recommended": false,
    "reference": "[RFC6209][RFC10015]"
  },
  {
    "value": "0xC0,0x44",
    "name": "TLS_DHE_RSA_WITH_ARIA_128_CBC_SHA256",
    "recommended": false,
    "reference": "[RFC6209][RFC10015]"
  },
  {
    "value": "0xC0,0x45",
    "name": "TLS_DHE_RSA_WITH_ARIA_256_CBC_SHA384",
    "recommended": false,
    "reference": "[RFC6209][RFC10015]"
  },
  {
    "value": "0xC0,0x46",
    "name": "TLS_DH_anon_WITH_ARIA_128_CBC_SHA256",
    "recommended": false,
    "reference": "[RFC6209][RFC10015]"
  },
  {
    "value": "0xC0,0x47",
    "name": "TLS_DH_anon_WITH_ARIA_256_CBC_SHA384",
    "recommended": false,
    "reference": "[RFC6209][RFC10015]"
  },
  {
    "value": "0xC0,0x48",
    "name": "TLS_ECDHE_ECDSA_WITH_ARIA_128_CBC_SHA256",
    "recommended": false,
    "reference": "[RFC6209]"
  },
  {
    "value": "0xC0,0x49",
    "name": "TLS_ECDHE_ECDSA_WITH_ARIA_256_CBC_SHA384",
    "recommended": false,
    "reference": "[RFC6209]"
  },
  {
    "value": "0xC0,0x4A",
    "name": "TLS_ECDH_ECDSA_WITH_ARIA_128_CBC_SHA256",
    "recommended": false,
    "reference": "[RFC6209][RFC10015]"
  },
  {
    "value": "0xC0,0x4B",
    "name": "TLS_ECDH_ECDSA_WITH_ARIA_256_CBC_SHA384",
    "recommended": false,
    "reference": "[RFC6209][RFC10015]"
  },
  {
    "value": "0xC0,0x4C",
    "name": "TLS_ECDHE_RSA_WITH_ARIA_128_CBC_SHA256",
    "recommended": false,
    "reference": "[RFC6209]"
  },
  {
    "value": "0xC0,0x4D",
    "name": "TLS_ECDHE_RSA_WITH_ARIA_256_CBC_SHA384",
    "recommended": false,
    "reference": "[RFC6209]"
  },
  {
    "value": "0xC0,0x4E",
    "name": "TLS_ECDH_RSA_WITH_ARIA_128_CBC_SHA256",
    "recommended": false,
    "reference": "[RFC6209][RFC10015]"
  },
  {
    "value": "0xC0,0x4F",
    "name": "TLS_ECDH_RSA_WITH_ARIA_256_CBC_SHA384",
    "recommended": false,
    "reference": "[RFC6209][RFC10015]"
  },
  {
    "value": "0xC0,0x50",
    "name": "TLS_RSA_WITH_ARIA_128_GCM_SHA256",
    "recommended": false,
    "reference": "[RFC6209][RFC10015]"
  },
  {
    "value": "0xC0,0x51",
    "name": "TLS_RSA_WITH_ARIA_256_GCM_SHA384",
    "recommended": false,
    "reference": "[RFC6209][RFC10015]"
  },
  {
    "value": "0xC0,0x52",
    "name": "TLS_DHE_RSA_WITH_ARIA_128_GCM_SHA256",
    "recommended": false,
    "reference": "[RFC6209][RFC10015]"
  },
  {
    "value": "0xC0,0x53",
    "name": "TLS_DHE_RSA_WITH_ARIA_256_GCM_SHA384",
    "recommended": false,
    "reference": "[RFC6209][RFC10015]"
  },
  {
    "value": "0xC0,0x54",
    "name": "TLS_DH_RSA_WITH_ARIA_128_GCM_SHA256",
    "recommended": false,
    "reference": "[RFC6209][RFC10015]"
  },
  {
    "value": "0xC0,0x55",
    "name": "TLS_DH_RSA_WITH_ARIA_256_GCM_SHA384",
    "recommended": false,
    "reference": "[RFC6209][RFC10015]"
  },
  {
    "value": "0xC0,0x56",
    "name": "TLS_DHE_DSS_WITH_ARIA_128_GCM_SHA256",
    "recommended": false,
    "reference": "[RFC6209][RFC10015]"
  },
  {
    "value": "0xC0,0x57",
    "name": "TLS_DHE_DSS_WITH_ARIA_256_GCM_SHA384",
    "recommended": false,
    "reference": "[RFC6209][RFC10015]"
  },
  {
    "value": "0xC0,0x58",
    "name": "TLS_DH_DSS_WITH_ARIA_128_GCM_SHA256",
    "recommended": false,
    "reference": "[RFC6209][RFC10015]"
  },
  {
    "value": "0xC0,0x59",
    "name": "TLS_DH_DSS_WITH_ARIA_256_GCM_SHA384",
    "recommended": false,
    "reference": "[RFC6209][RFC10015]"
  },
  {
    "value": "0xC0,0x5A",
    "name": "TLS_DH_anon_WITH_ARIA_128_GCM_SHA256",
    "recommended": false,
    "reference": "[RFC6209][RFC10015]"
  },
  {
    "value": "0xC0,0x5B",
    "name": "TLS_DH_anon_WITH_ARIA_256_GCM_SHA384",
    "recommended": false,
    "reference": "[RFC6209][RFC10015]"
  },
  {
    "value": "0xC0,0x5C",
    "name": "TLS_ECDHE_ECDSA_WITH_ARIA_128_GCM_SHA256",
    "recommended": false,
    "reference": "[RFC6209]"
  },
  {
    "value": "0xC0,0x5D",
    "name": "TLS_ECDHE_ECDSA_WITH_ARIA_256_GCM_SHA384",
    "recommended": false,
    "reference": "[RFC6209]"
  },
  {
    "value": "0xC0,0x5E",
    "name": "TLS_ECDH_ECDSA_WITH_ARIA_128_GCM_SHA256",
    "recommended": false,
    "reference": "[RFC6209][RFC10015]"
  },
  {
    "value": "0xC0,0x5F",
    "name": "TLS_ECDH_ECDSA_WITH_ARIA_256_GCM_SHA384",
    "recommended": false,
    "reference": "[RFC6209][RFC10015]"
  },
  {
    "value": "0xC0,0x60",
    "name": "TLS_ECDHE_RSA_WITH_ARIA_128_GCM_SHA256",
    "recommended": false,
    "reference": "[RFC6209]"
  },
  {
    "value": "0xC0,0x61",
    "name": "TLS_ECDHE_RSA_WITH_ARIA_256_GCM_SHA384",
    "recommended": false,
    "reference": "[RFC6209]"
  },
  {
    "value": "0xC0,0x62",
    "name": "TLS_ECDH_RSA_WITH_ARIA_128_GCM_SHA256",
    "recommended": false,
    "reference": "[RFC6209][RFC10015]"
  },
  {
    "value": "0xC0,0x63",
    "name": "TLS_ECDH_RSA_WITH_ARIA_256_GCM_SHA384",
    "recommended": false,
    "reference": "[RFC6209][RFC10015]"
  },
  {
    "value": "0xC0,0x64",
    "name": "TLS_PSK_WITH_ARIA_128_CBC_SHA256",
    "recommended": false,
    "reference": "[RFC6209]"
  },
  {
    "value": "0xC0,0x65",
    "name": "TLS_PSK_WITH_ARIA_256_CBC_SHA384",
    "recommended": false,
    "reference": "[RFC6209]"
  },
  {
    "value": "0xC0,0x66",
    "name": "TLS_DHE_PSK_WITH_ARIA_128_CBC_SHA256",
    "recommended": false,
    "reference": "[RFC6209][RFC10015]"
  },
  {
    "value": "0xC0,0x67",
    "name": "TLS_DHE_PSK_WITH_ARIA_256_CBC_SHA384",
    "recommended": false,
    "reference": "[RFC6209][RFC10015]"
  },
  {
    "value": "0xC0,0x68",
    "name": "TLS_RSA_PSK_WITH_ARIA_128_CBC_SHA256",
    "recommended": false,
    "reference": "[RFC6209][RFC10015]"
  },
  {
    "value": "0xC0,0x69",
    "name": "TLS_RSA_PSK_WITH_ARIA_256_CBC_SHA384",
    "recommended": false,
    "reference": "[RFC6209][RFC10015]"
  },
  {
    "value": "0xC0,0x6A",
    "name": "TLS_PSK_WITH_ARIA_128_GCM_SHA256",
    "recommended": false,
    "reference": "[RFC6209]"
  },
  {
    "value": "0xC0,0x6B",
    "name": "TLS_PSK_WITH_ARIA_256_GCM_SHA384",
    "recommended": false,
    "reference": "[RFC6209]"
  },
  {
    "value": "0xC0,0x6C",
    "name": "TLS_DHE_PSK_WITH_ARIA_128_GCM_SHA256",
    "recommended": false,
    "reference": "[RFC6209][RFC10015]"
  },
  {
    "value": "0xC0,0x6D",
    "name": "TLS_DHE_PSK_WITH_ARIA_256_GCM_SHA384",
    "recommended": false,
    "reference": "[RFC6209][RFC10015]"
  },
  {
    "value": "0xC0,0x6E",
    "name": "TLS_RSA_PSK_WITH_ARIA_128_GCM_SHA256",
    "recommended": false,
    "reference": "[RFC6209][RFC10015]"
  },
  {
    "value": "0xC0,0x6F",
    "name": "TLS_RSA_PSK_WITH_ARIA_256_GCM_SHA384",
    "recommended": false,
    "reference": "[RFC6209][RFC10015]"
  },
  {
    "value": "0xC0,0x70",
    "name": "TLS_ECDHE_PSK_WITH_ARIA_128_CBC_SHA256",
    "recommended": false,
    "reference": "[RFC6209]"
  },
  {
    "value": "0xC0,0x71",
    "name": "TLS_ECDHE_PSK_WITH_ARIA_256_CBC_SHA384",
    "recommended": false,
    "reference": "[RFC6209]"
  },
  {
    "value": "0xC0,0x72",
    "name": "TLS_ECDHE_ECDSA_WITH_CAMELLIA_128_CBC_SHA256",
    "recommended": false,
    "reference": "[RFC6367]"
  },
  {
    "value": "0xC0,0x73",
    "name": "TLS_ECDHE_ECDSA_WITH_CAMELLIA_256_CBC_SHA384",
    "recommended": false,
    "reference": "[RFC6367]"
  },
  {
    "value": "0xC0,0x74",
    "name": "TLS_ECDH_ECDSA_WITH_CAMELLIA_128_CBC_SHA256",
    "recommended": false,
    "reference": "[RFC6367][RFC10015]"
  },
  {
    "value": "0xC0,0x75",
    "name": "TLS_ECDH_ECDSA_WITH_CAMELLIA_256_CBC_SHA384",
    "recommended": false,
    "reference": "[RFC6367][RFC10015]"
  },
  {
    "value": "0xC0,0x76",
    "name": "TLS_ECDHE_RSA_WITH_CAMELLIA_128_CBC_SHA256",
    "recommended": false,
    "reference": "[RFC6367]"
  },
  {
    "value": "0xC0,0x77",
    "name": "TLS_ECDHE_RSA_WITH_CAMELLIA_256_CBC_SHA384",
    "recommended": false,
    "reference": "[RFC6367]"
  },
  {
    "value": "0xC0,0x78",
    "name": "TLS_ECDH_RSA_WITH_CAMELLIA_128_CBC_SHA256",
    "recommended": false,
    "reference": "[RFC6367][RFC10015]"
  },
  {
    "value": "0xC0,0x79",
    "name": "TLS_ECDH_RSA_WITH_CAMELLIA_256_CBC_SHA384",
    "recommended": false,
    "reference": "[RFC6367][RFC10015]"
  },
  {
    "value": "0xC0,0x7A",
    "name": "TLS_RSA_WITH_CAMELLIA_128_GCM_SHA256",
    "recommended": false,
    "reference": "[RFC6367][RFC10015]"
  },
  {
    "value": "0xC0,0x7B",
    "name": "TLS_RSA_WITH_CAMELLIA_256_GCM_SHA384",
    "recommended": false,
    "reference": "[RFC6367][RFC10015]"
  },
  {
    "value": "0xC0,0x7C",
    "name": "TLS_DHE_RSA_WITH_CAMELLIA_128_GCM_SHA256",
    "recommended": false,
    "reference": "[RFC6367][RFC10015]"
  },
  {
    "value": "0xC0,0x7D",
    "name": "TLS_DHE_RSA_WITH_CAMELLIA_256_GCM_SHA384",
    "recommended": false,
    "reference": "[RFC6367][RFC10015]"
  },
  {
    "value": "0xC0,0x7E",
    "name": "TLS_DH_RSA_WITH_CAMELLIA_128_GCM_SHA256",
    "recommended": false,
    "reference": "[RFC6367][RFC10015]"
  },
  {
    "value": "0xC0,0x7F",
    "name": "TLS_DH_RSA_WITH_CAMELLIA_256_GCM_SHA384",
    "recommended": false,
    "reference": "[RFC6367][RFC10015]"
  },
  {
    "value": "0xC0,0x80",
    "name": "TLS_DHE_DSS_WITH_CAMELLIA_128_GCM_SHA256",
    "recommended": false,
    "reference": "[RFC6367][RFC10015]"
  },
  {
    "value": "0xC0,0x81",
    "name": "TLS_DHE_DSS_WITH_CAMELLIA_256_GCM_SHA384",
    "recommended": false,
    "reference": "[RFC6367][RFC10015]"
  },
  {
    "value": "0xC0,0x82",
    "name": "TLS_DH_DSS_WITH_CAMELLIA_128_GCM_SHA256",
    "recommended": false,
    "reference": "[RFC6367][RFC10015]"
  },
  {
    "value": "0xC0,0x83",
    "name": "TLS_DH_DSS_WITH_CAMELLIA_256_GCM_SHA384",
    "recommended": false,
    "reference": "[RFC6367][RFC10015]"
  },
  {
    "value": "0xC0,0x84",
    "name": "TLS_DH_anon_WITH_CAMELLIA_128_GCM_SHA256",
    "recommended": false,
    "reference": "[RFC6367][RFC10015]"
  },
  {
    "value": "0xC0,0x85",
    "name": "TLS_DH_anon_WITH_CAMELLIA_256_GCM_SHA384",
    "recommended": false,
    "reference": "[RFC6367][RFC10015]"
  },
  {
    "value": "0xC0,0x86",
    "name": "TLS_ECDHE_ECDSA_WITH_CAMELLIA_128_GCM_SHA256",
    "recommended": false,
    "reference": "[RFC6367]"
  },
  {
    "value": "0xC0,0x87",
    "name": "TLS_ECDHE_ECDSA_WITH_CAMELLIA_256_GCM_SHA384",
    "recommended": false,
    "reference": "[RFC6367]"
  },
  {
    "value": "0xC0,0x88",
    "name": "TLS_ECDH_ECDSA_WITH_CAMELLIA_128_GCM_SHA256",
    "recommended": false,
    "reference": "[RFC6367][RFC10015]"
  },
  {
    "value": "0xC0,0x89",
    "name": "TLS_ECDH_ECDSA_WITH_CAMELLIA_256_GCM_SHA384",
    "recommended": false,
    "reference": "[RFC6367][RFC10015]"
  },
  {
    "value": "0xC0,0x8A",
    "name": "TLS_ECDHE_RSA_WITH_CAMELLIA_128_GCM_SHA256",
    "recommended": false,
    "reference": "[RFC6367]"
  },
  {
    "value": "0xC0,0x8B",
    "name": "TLS_ECDHE_RSA_WITH_CAMELLIA_256_GCM_SHA384",
    "recommended": false,
    "reference": "[RFC6367]"
  },
  {
    "value": "0xC0,0x8C",
    "name": "TLS_ECDH_RSA_WITH_CAMELLIA_128_GCM_SHA256",
    "recommended": false,
    "reference": "[RFC6367][RFC10015]"
  },
  {
    "value": "0xC0,0x8D",
    "name": "TLS_ECDH_RSA_WITH_CAMELLIA_256_GCM_SHA384",
    "recommended": false,
    "reference": "[RFC6367][RFC10015]"
  },
  {
    "value": "0xC0,0x8E",
    "name": "TLS_PSK_WITH_CAMELLIA_128_GCM_SHA256",
    "recommended": false,
    "reference": "[RFC6367]"
  },
  {
    "value": "0xC0,0x8F",
    "name": "TLS_PSK_WITH_CAMELLIA_256_GCM_SHA384",
    "recommended": false,
    "reference": "[RFC6367]"
  },
  {
    "value": "0xC0,0x90",
    "name": "TLS_DHE_PSK_WITH_CAMELLIA_128_GCM_SHA256",
    "recommended": false,
    "reference": "[RFC6367][RFC10015]"
  },
  {
    "value": "0xC0,0x91",
    "name": "TLS_DHE_PSK_WITH_CAMELLIA_256_GCM_SHA384",
    "recommended": false,
    "reference": "[RFC6367][RFC10015]"
  },
  {
    "value": "0xC0,0x92",
    "name": "TLS_RSA_PSK_WITH_CAMELLIA_128_GCM_SHA256",
    "recommended": false,
    "reference": "[RFC6367][RFC10015]"
  },
  {
    "value": "0xC0,0x93",
    "name": "TLS_RSA_PSK_WITH_CAMELLIA_256_GCM_SHA384",
    "recommended": false,
    "reference": "[RFC6367][RFC10015]"
  },
  {
    "value": "0xC0,0x94",
    "name": "TLS_PSK_WITH_CAMELLIA_128_CBC_SHA256",
    "recommended": false,
    "reference": "[RFC6367]"
  },
  {
    "value": "0xC0,0x95",
    "name": "TLS_PSK_WITH_CAMELLIA_256_CBC_SHA384",
    "recommended": false,
    "reference": "[RFC6367]"
  },
  {
    "value": "0xC0,0x96",
    "name": "TLS_DHE_PSK_WITH_CAMELLIA_128_CBC_SHA256",
    "recommended": false,
    "reference": "[RFC6367][RFC10015]"
  },
  {
    "value": "0xC0,0x97",
    "name": "TLS_DHE_PSK_WITH_CAMELLIA_256_CBC_SHA384",
    "recommended": false,
    "reference": "[RFC6367][RFC10015]"
  },
  {
    "value": "0xC0,0x98",
    "name": "TLS_RSA_PSK_WITH_CAMELLIA_128_CBC_SHA256",
    "recommended": false,
    "reference": "[RFC6367][RFC10015]"
  },
  {
    "value": "0xC0,0x99",
    "name": "TLS_RSA_PSK_WITH_CAMELLIA_256_CBC_SHA384",
    "recommended": false,
    "reference": "[RFC6367][RFC10015]"
  },
  {
    "value": "0xC0,0x9A",
    "name": "TLS_ECDHE_PSK_WITH_CAMELLIA_128_CBC_SHA256",
    "recommended": false,
    "reference": "[RFC6367]"
  },
  {
    "value": "0xC0,0x9B",
    "name": "TLS_ECDHE_PSK_WITH_CAMELLIA_256_CBC_SHA384",
    "recommended": false,
    "reference": "[RFC6367]"
  },
  {
    "value": "0xC0,0x9C",
    "name": "TLS_RSA_WITH_AES_128_CCM",
    "recommended": false,
    "reference": "[RFC6655][RFC10015]"
  },
  {
    "value": "0xC0,0x9D",
    "name": "TLS_RSA_WITH_AES_256_CCM",
    "recommended": false,
    "reference": "[RFC6655][RFC10015]"
  },
  {
    "value": "0xC0,0x9E",
    "name": "TLS_DHE_RSA_WITH_AES_128_CCM",
    "recommended": false,
    "reference": "[RFC6655][RFC10015]"
  },
  {
    "value": "0xC0,0x9F",
    "name": "TLS_DHE_RSA_WITH_AES_256_CCM",
    "recommended": false,
    "reference": "[RFC6655][RFC10015]"
  },
  {
    "value": "0xC0,0xA0",
    "name": "TLS_RSA_WITH_AES_128_CCM_8",
    "recommended": false,
    "reference": "[RFC6655][RFC10015]"
  },
  {
    "value": "0xC0,0xA1",
    "name": "TLS_RSA_WITH_AES_256_CCM_8",
    "recommended": false,
    "reference": "[RFC6655][RFC10015]"
  },
  {
    "value": "0xC0,0xA2",
    "name": "TLS_DHE_RSA_WITH_AES_128_CCM_8",
    "recommended": false,
    "reference": "[RFC6655][RFC10015]"
  },
  {
    "value": "0xC0,0xA3",
    "name": "TLS_DHE_RSA_WITH_AES_256_CCM_8",
    "recommended": false,
    "reference": "[RFC6655][RFC10015]"
  },
  {
    "value": "0xC0,0xA4",
    "name": "TLS_PSK_WITH_AES_128_CCM",
    "recommended": false,
    "reference": "[RFC6655]"
  },
  {
    "value": "0xC0,0xA5",
    "name": "TLS_PSK_WITH_AES_256_CCM",
    "recommended": false,
    "reference": "[RFC6655]"
  },
  {
    "value": "0xC0,0xA6",
    "name": "TLS_DHE_PSK_WITH_AES_128_CCM",
    "recommended": false,
    "reference": "[RFC6655][RFC10015]"
  },
  {
    "value": "0xC0,0xA7",
    "name": "TLS_DHE_PSK_WITH_AES_256_CCM",
    "recommended": false,
    "reference": "[RFC6655][RFC10015]"
  },
  {
    "value": "0xC0,0xA8",
    "name": "TLS_PSK_WITH_AES_128_CCM_8",
    "recommended": false,
    "reference": "[RFC6655]"
  },
  {
    "value": "0xC0,0xA9",
    "name": "TLS_PSK_WITH_AES_256_CCM_8",
    "recommended": false,
    "reference": "[RFC6655]"
  },
  {
    "value": "0xC0,0xAA",
    "name": "TLS_PSK_DHE_WITH_AES_128_CCM_8",
    "recommended": false,
    "reference": "[RFC6655][RFC10015]"
  },
  {
    "value": "0xC0,0xAB",
    "name": "TLS_PSK_DHE_WITH_AES_256_CCM_8",
    "recommended": false,
    "reference": "[RFC6655][RFC10015]"
  },
  {
    "value": "0xC0,0xAC",
    "name": "TLS_ECDHE_ECDSA_WITH_AES_128_CCM",
    "recommended": false,
    "reference": "[RFC7251]"
  },
  {
    "value": "0xC0,0xAD",
    "name": "TLS_ECDHE_ECDSA_WITH_AES_256_CCM",
    "recommended": false,
    "reference": "[RFC7251]"
  },
  {
    "value": "0xC0,0xAE",
    "name": "TLS_ECDHE_ECDSA_WITH_AES_128_CCM_8",
    "recommended": false,
    "reference": "[RFC7251]"
  },
  {
    "value": "0xC0,0xAF",
    "name": "TLS_ECDHE_ECDSA_WITH_AES_256_CCM_8",
    "recommended": false,
    "reference": "[RFC7251]"
  },
  {
    "value": "0xC0,0xB0",
    "name": "TLS_ECCPWD_WITH_AES_128_GCM_SHA256",
    "recommended": false,
    "reference": "[RFC8492]"
  },
  {
    "value": "0xC0,0xB1",
    "name": "TLS_ECCPWD_WITH_AES_256_GCM_SHA384",
    "recommended": false,
    "reference": "[RFC8492]"
  },
  {
    "value": "0xC0,0xB2",
    "name": "TLS_ECCPWD_WITH_AES_128_CCM_SHA256",
    "recommended": false,
    "reference": "[RFC8492]"
  },
  {
    "value": "0xC0,0xB3",
    "name": "TLS_ECCPWD_WITH_AES_256_CCM_SHA384",
    "recommended": false,
    "reference": "[RFC8492]"
  },
  {
    "value": "0xC0,0xB4",
    "name": "TLS_SHA256_SHA256",
    "recommended": false,
    "reference": "[RFC9150][RFC9847]"
  },
  {
    "value": "0xC0,0xB5",
    "name": "TLS_SHA384_SHA384",
    "recommended": false,
    "reference": "[RFC9150][RFC9847]"
  },
  {
    "value": "0xC1,0x00",
    "name": "TLS_GOSTR341112_256_WITH_KUZNYECHIK_CTR_OMAC",
    "recommended": false,
    "reference": "[RFC9189]"
  },
  {
    "value": "0xC1,0x01",
    "name": "TLS_GOSTR341112_256_WITH_MAGMA_CTR_OMAC",
    "recommended": false,
    "reference": "[RFC9189]"
  },
  {
    "value": "0xC1,0x02",
    "name": "TLS_GOSTR341112_256_WITH_28147_CNT_IMIT",
    "recommended": false,
    "reference": "[RFC9189]"
  },
  {
    "value": "0xC1,0x03",
    "name": "TLS_GOSTR341112_256_WITH_KUZNYECHIK_MGM_L",
    "recommended": false,
    "reference": "[RFC9367]"
  },
  {
    "value": "0xC1,0x04",
    "name": "TLS_GOSTR341112_256_WITH_MAGMA_MGM_L",
    "recommended": false,
    "reference": "[RFC9367]"
  },
  {
    "value": "0xC1,0x05",
    "name": "TLS_GOSTR341112_256_WITH_KUZNYECHIK_MGM_S",
    "recommended": false,
    "reference": "[RFC9367]"
  },
  {
    "value": "0xC1,0x06",
    "name": "TLS_GOSTR341112_256_WITH_MAGMA_MGM_S",
    "recommended": false,
    "reference": "[RFC9367]"
  },
  {
    "value": "0xCC,0xA8",
    "name": "TLS_ECDHE_RSA_WITH_CHACHA20_POLY1305_SHA256",
    "recommended": true,
    "reference": "[RFC7905]"
  },
  {
    "value": "0xCC,0xA9",
    "name": "TLS_ECDHE_ECDSA_WITH_CHACHA20_POLY1305_SHA256",
    "recommended": true,
    "reference": "[RFC7905]"
  },
  {
    "value": "0xCC,0xAA",
    "name": "TLS_DHE_RSA_WITH_CHACHA20_POLY1305_SHA256",
    "recommended": false,
    "reference": "[RFC7905][RFC10015]"
  },
  {
    "value": "0xCC,0xAB",
    "name": "TLS_PSK_WITH_CHACHA20_POLY1305_SHA256",
    "recommended": false,
    "reference": "[RFC7905]"
  },
  {
    "value": "0xCC,0xAC",
    "name": "TLS_ECDHE_PSK_WITH_CHACHA20_POLY1305_SHA256",
    "recommended": true,
    "reference": "[RFC7905]"
  },
  {
    "value": "0xCC,0xAD",
    "name": "TLS_DHE_PSK_WITH_CHACHA20_POLY1305_SHA256",
    "recommended": false,
    "reference": "[RFC7905][RFC10015]"
  },
  {
    "value": "0xCC,0xAE",
    "name": "TLS_RSA_PSK_WITH_CHACHA20_POLY1305_SHA256",
    "recommended": false,
    "reference": "[RFC7905][RFC10015]"
  },
  {
    "value": "0xD0,0x01",
    "name": "TLS_ECDHE_PSK_WITH_AES_128_GCM_SHA256",
    "recommended": true,
    "reference": "[RFC8442]"
  },
  {
    "value": "0xD0,0x02",
    "name": "TLS_ECDHE_PSK_WITH_AES_256_GCM_SHA384",
    "recommended": true,
    "reference": "[RFC8442]"
  },
  {
    "value": "0xD0,0x03",
    "name": "TLS_ECDHE_PSK_WITH_AES_128_CCM_8_SHA256",
    "recommended": false,
    "reference": "[RFC8442]"
  },
  {
    "value": "0xD0,0x05",
    "name": "TLS_ECDHE_PSK_WITH_AES_128_CCM_SHA256",
    "recommended": true,
    "reference": "[RFC8442]"
  }
] as const;

export type CipherSuite = (typeof tlsCipherSuites)[number];
