// staticdata.dev — dnsRecordTypes
// Generated file. Do not edit by hand.
// SPDX-License-Identifier: MIT

export const dnsRecordTypes = [
  {
    "type": "A",
    "value": 1,
    "description": "a host address",
    "reference": "[RFC1035]"
  },
  {
    "type": "NS",
    "value": 2,
    "description": "an authoritative name server",
    "reference": "[RFC1035]"
  },
  {
    "type": "MD",
    "value": 3,
    "description": "a mail destination (OBSOLETE - use MX)",
    "reference": "[RFC1035]"
  },
  {
    "type": "MF",
    "value": 4,
    "description": "a mail forwarder (OBSOLETE - use MX)",
    "reference": "[RFC1035]"
  },
  {
    "type": "CNAME",
    "value": 5,
    "description": "the canonical name for an alias",
    "reference": "[RFC1035]"
  },
  {
    "type": "SOA",
    "value": 6,
    "description": "marks the start of a zone of authority",
    "reference": "[RFC1035]"
  },
  {
    "type": "MB",
    "value": 7,
    "description": "a mailbox domain name (EXPERIMENTAL)",
    "reference": "[RFC1035]"
  },
  {
    "type": "MG",
    "value": 8,
    "description": "a mail group member (EXPERIMENTAL)",
    "reference": "[RFC1035]"
  },
  {
    "type": "MR",
    "value": 9,
    "description": "a mail rename domain name (EXPERIMENTAL)",
    "reference": "[RFC1035]"
  },
  {
    "type": "NULL",
    "value": 10,
    "description": "a null RR (EXPERIMENTAL)",
    "reference": "[RFC1035]"
  },
  {
    "type": "WKS",
    "value": 11,
    "description": "a well known service description",
    "reference": "[RFC1035]"
  },
  {
    "type": "PTR",
    "value": 12,
    "description": "a domain name pointer",
    "reference": "[RFC1035]"
  },
  {
    "type": "HINFO",
    "value": 13,
    "description": "host information",
    "reference": "[RFC1035]"
  },
  {
    "type": "MINFO",
    "value": 14,
    "description": "mailbox or mail list information",
    "reference": "[RFC1035]"
  },
  {
    "type": "MX",
    "value": 15,
    "description": "mail exchange",
    "reference": "[RFC1035]"
  },
  {
    "type": "TXT",
    "value": 16,
    "description": "text strings",
    "reference": "[RFC1035]"
  },
  {
    "type": "RP",
    "value": 17,
    "description": "for Responsible Person",
    "reference": "[RFC1183]"
  },
  {
    "type": "AFSDB",
    "value": 18,
    "description": "for AFS Data Base location",
    "reference": "[RFC1183][RFC5864]"
  },
  {
    "type": "X25",
    "value": 19,
    "description": "for X.25 PSDN address",
    "reference": "[RFC1183]"
  },
  {
    "type": "ISDN",
    "value": 20,
    "description": "for ISDN address",
    "reference": "[RFC1183]"
  },
  {
    "type": "RT",
    "value": 21,
    "description": "for Route Through",
    "reference": "[RFC1183]"
  },
  {
    "type": "NSAP",
    "value": 22,
    "description": "for NSAP address, NSAP style A record (DEPRECATED)",
    "reference": "[RFC1706][Moving TPC.INT and NSAP.INT infrastructure domains to historic]"
  },
  {
    "type": "NSAP-PTR",
    "value": 23,
    "description": "for domain name pointer, NSAP style (DEPRECATED)",
    "reference": "[RFC1706][Moving TPC.INT and NSAP.INT infrastructure domains to historic]"
  },
  {
    "type": "SIG",
    "value": 24,
    "description": "for security signature",
    "reference": "[RFC2536][RFC2931][RFC3110][RFC4034]"
  },
  {
    "type": "KEY",
    "value": 25,
    "description": "for security key",
    "reference": "[RFC2536][RFC2539][RFC3110][RFC4034]"
  },
  {
    "type": "PX",
    "value": 26,
    "description": "X.400 mail mapping information",
    "reference": "[RFC2163]"
  },
  {
    "type": "GPOS",
    "value": 27,
    "description": "Geographical Position",
    "reference": "[RFC1712]"
  },
  {
    "type": "AAAA",
    "value": 28,
    "description": "IP6 Address",
    "reference": "[RFC3596]"
  },
  {
    "type": "LOC",
    "value": 29,
    "description": "Location Information",
    "reference": "[RFC1876]"
  },
  {
    "type": "NXT",
    "value": 30,
    "description": "Next Domain (OBSOLETE)",
    "reference": "[RFC2535][RFC3755]"
  },
  {
    "type": "EID",
    "value": 31,
    "description": "Endpoint Identifier",
    "reference": "[Michael_Patton][http://ana-3.lcs.mit.edu/~jnc/nimrod/dns.txt]"
  },
  {
    "type": "NIMLOC",
    "value": 32,
    "description": "Nimrod Locator",
    "reference": "[1][Michael_Patton][http://ana-3.lcs.mit.edu/~jnc/nimrod/dns.txt]"
  },
  {
    "type": "SRV",
    "value": 33,
    "description": "Server Selection",
    "reference": "[1][RFC2782]"
  },
  {
    "type": "ATMA",
    "value": 34,
    "description": "ATM Address",
    "reference": "[ATM Forum AF-DANS-0152.000]"
  },
  {
    "type": "NAPTR",
    "value": 35,
    "description": "Naming Authority Pointer",
    "reference": "[RFC3403]"
  },
  {
    "type": "KX",
    "value": 36,
    "description": "Key Exchanger",
    "reference": "[RFC2230]"
  },
  {
    "type": "CERT",
    "value": 37,
    "description": "CERT",
    "reference": "[RFC4398]"
  },
  {
    "type": "A6",
    "value": 38,
    "description": "A6 (OBSOLETE - use AAAA)",
    "reference": "[RFC2874][RFC3226][RFC6563]"
  },
  {
    "type": "DNAME",
    "value": 39,
    "description": "DNAME",
    "reference": "[RFC6672]"
  },
  {
    "type": "SINK",
    "value": 40,
    "description": "SINK",
    "reference": "[Donald_E_Eastlake][draft-eastlake-kitchen-sink-02]"
  },
  {
    "type": "OPT",
    "value": 41,
    "description": "OPT",
    "reference": "[RFC3225][RFC6891]"
  },
  {
    "type": "APL",
    "value": 42,
    "description": "APL",
    "reference": "[RFC3123]"
  },
  {
    "type": "DS",
    "value": 43,
    "description": "Delegation Signer",
    "reference": "[RFC4034]"
  },
  {
    "type": "SSHFP",
    "value": 44,
    "description": "SSH Key Fingerprint",
    "reference": "[RFC4255]"
  },
  {
    "type": "IPSECKEY",
    "value": 45,
    "description": "IPSECKEY",
    "reference": "[RFC4025]"
  },
  {
    "type": "RRSIG",
    "value": 46,
    "description": "RRSIG",
    "reference": "[RFC4034]"
  },
  {
    "type": "NSEC",
    "value": 47,
    "description": "NSEC",
    "reference": "[RFC4034][RFC9077]"
  },
  {
    "type": "DNSKEY",
    "value": 48,
    "description": "DNSKEY",
    "reference": "[RFC4034]"
  },
  {
    "type": "DHCID",
    "value": 49,
    "description": "DHCID",
    "reference": "[RFC4701]"
  },
  {
    "type": "NSEC3",
    "value": 50,
    "description": "NSEC3",
    "reference": "[RFC5155][RFC9077]"
  },
  {
    "type": "NSEC3PARAM",
    "value": 51,
    "description": "NSEC3PARAM",
    "reference": "[RFC5155]"
  },
  {
    "type": "TLSA",
    "value": 52,
    "description": "TLSA",
    "reference": "[RFC6698]"
  },
  {
    "type": "SMIMEA",
    "value": 53,
    "description": "S/MIME cert association",
    "reference": "[RFC8162]"
  },
  {
    "type": "HIP",
    "value": 55,
    "description": "Host Identity Protocol",
    "reference": "[RFC8005]"
  },
  {
    "type": "NINFO",
    "value": 56,
    "description": "NINFO",
    "reference": "[Jim_Reid]"
  },
  {
    "type": "RKEY",
    "value": 57,
    "description": "RKEY",
    "reference": "[Jim_Reid]"
  },
  {
    "type": "TALINK",
    "value": 58,
    "description": "Trust Anchor LINK",
    "reference": "[Wouter_Wijngaards]"
  },
  {
    "type": "CDS",
    "value": 59,
    "description": "Child DS",
    "reference": "[RFC7344]"
  },
  {
    "type": "CDNSKEY",
    "value": 60,
    "description": "DNSKEY(s) the Child wants reflected in DS",
    "reference": "[RFC7344]"
  },
  {
    "type": "OPENPGPKEY",
    "value": 61,
    "description": "OpenPGP Key",
    "reference": "[RFC7929]"
  },
  {
    "type": "CSYNC",
    "value": 62,
    "description": "Child-To-Parent Synchronization",
    "reference": "[RFC7477]"
  },
  {
    "type": "ZONEMD",
    "value": 63,
    "description": "Message Digest Over Zone Data",
    "reference": "[RFC8976]"
  },
  {
    "type": "SVCB",
    "value": 64,
    "description": "General-purpose service binding",
    "reference": "[RFC9460]"
  },
  {
    "type": "HTTPS",
    "value": 65,
    "description": "SVCB-compatible type for use with HTTP",
    "reference": "[RFC9460]"
  },
  {
    "type": "DSYNC",
    "value": 66,
    "description": "Endpoint discovery for delegation synchronization",
    "reference": "[RFC9859]"
  },
  {
    "type": "HHIT",
    "value": 67,
    "description": "Hierarchical Host Identity Tag",
    "reference": "[RFC9886]"
  },
  {
    "type": "BRID",
    "value": 68,
    "description": "UAS Broadcast Remote Identification",
    "reference": "[RFC9886]"
  },
  {
    "type": "UNECE",
    "value": 69,
    "description": "Value coded per a UNECE Recommendation",
    "reference": "[draft-woodcock-faltstrom-external-registry-rrtypes-00]"
  },
  {
    "type": "ISO",
    "value": 70,
    "description": "Value coded per an ISO standard",
    "reference": "[draft-woodcock-faltstrom-external-registry-rrtypes-00]"
  },
  {
    "type": "SPF",
    "value": 99,
    "description": null,
    "reference": "[RFC7208]"
  },
  {
    "type": "UINFO",
    "value": 100,
    "description": null,
    "reference": "[IANA-Reserved]"
  },
  {
    "type": "UID",
    "value": 101,
    "description": null,
    "reference": "[IANA-Reserved]"
  },
  {
    "type": "GID",
    "value": 102,
    "description": null,
    "reference": "[IANA-Reserved]"
  },
  {
    "type": "UNSPEC",
    "value": 103,
    "description": null,
    "reference": "[IANA-Reserved]"
  },
  {
    "type": "NID",
    "value": 104,
    "description": null,
    "reference": "[RFC6742]"
  },
  {
    "type": "L32",
    "value": 105,
    "description": null,
    "reference": "[RFC6742]"
  },
  {
    "type": "L64",
    "value": 106,
    "description": null,
    "reference": "[RFC6742]"
  },
  {
    "type": "LP",
    "value": 107,
    "description": null,
    "reference": "[RFC6742]"
  },
  {
    "type": "EUI48",
    "value": 108,
    "description": "an EUI-48 address",
    "reference": "[RFC7043]"
  },
  {
    "type": "EUI64",
    "value": 109,
    "description": "an EUI-64 address",
    "reference": "[RFC7043]"
  },
  {
    "type": "NXNAME",
    "value": 128,
    "description": "NXDOMAIN indicator for Compact Denial of Existence",
    "reference": "[RFC9824]"
  },
  {
    "type": "TKEY",
    "value": 249,
    "description": "Transaction Key",
    "reference": "[RFC2930]"
  },
  {
    "type": "TSIG",
    "value": 250,
    "description": "Transaction Signature",
    "reference": "[RFC8945]"
  },
  {
    "type": "IXFR",
    "value": 251,
    "description": "incremental transfer",
    "reference": "[RFC1995]"
  },
  {
    "type": "AXFR",
    "value": 252,
    "description": "transfer of an entire zone",
    "reference": "[RFC1035][RFC5936]"
  },
  {
    "type": "MAILB",
    "value": 253,
    "description": "mailbox-related RRs (MB, MG or MR)",
    "reference": "[RFC1035]"
  },
  {
    "type": "MAILA",
    "value": 254,
    "description": "mail agent RRs (OBSOLETE - see MX)",
    "reference": "[RFC1035]"
  },
  {
    "type": "*",
    "value": 255,
    "description": "A request for some or all records the server has available",
    "reference": "[RFC1035][RFC6895][RFC8482]"
  },
  {
    "type": "URI",
    "value": 256,
    "description": "URI",
    "reference": "[RFC7553]"
  },
  {
    "type": "CAA",
    "value": 257,
    "description": "Certification Authority Restriction",
    "reference": "[RFC8659]"
  },
  {
    "type": "AVC",
    "value": 258,
    "description": "Application Visibility and Control",
    "reference": "[Wolfgang_Riedel]"
  },
  {
    "type": "DOA",
    "value": 259,
    "description": "Digital Object Architecture",
    "reference": "[draft-durand-doa-over-dns-02]"
  },
  {
    "type": "AMTRELAY",
    "value": 260,
    "description": "Automatic Multicast Tunneling Relay",
    "reference": "[RFC8777]"
  },
  {
    "type": "RESINFO",
    "value": 261,
    "description": "Resolver Information as Key/Value Pairs",
    "reference": "[RFC9606]"
  },
  {
    "type": "WALLET",
    "value": 262,
    "description": "Public wallet address",
    "reference": "[Paul_Hoffman]"
  },
  {
    "type": "CLA",
    "value": 263,
    "description": "BP Convergence Layer Adapter",
    "reference": "[draft-johnson-dns-ipn-cla-07]"
  },
  {
    "type": "IPN",
    "value": 264,
    "description": "BP Node Number",
    "reference": "[draft-johnson-dns-ipn-cla-07]"
  },
  {
    "type": "TA",
    "value": 32768,
    "description": "DNSSEC Trust Authorities",
    "reference": "[Sam_Weiler][CMU TR 1999-19]"
  },
  {
    "type": "DLV",
    "value": 32769,
    "description": "DNSSEC Lookaside Validation (OBSOLETE)",
    "reference": "[RFC8749][RFC4431]"
  }
] as const;

export type DnsRecordType = (typeof dnsRecordTypes)[number];
